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Using VMware Horizon Client for Mac OS X

Using VMware Horizon Client for Mac OS X provides information about installing and using  VMware
Horizon™ Client™ software on a Mac to connect to a remote desktop or application in the datacenter.

This information is intended for administrators who need to set up a View deployment that includes Mac
client devices. The information is written for experienced system administrators who are familiar with
virtual machine technology and datacenter operations.
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Setup and Installation 1
Setting up a View deployment for Mac clients involves using certain View Connection Server configuration
settings, meeting the system requirements for View servers and Mac clients, and downloading and
installing Horizon Client for Mac from the VMware Web site.

This chapter includes the following topics:

n “System Requirements for Mac Clients,” on page 7

n “System Requirements for Real-Time Audio-Video,” on page 8

n “Smart Card Authentication Requirements,” on page 9

n “Supported Desktop Operating Systems,” on page 9

n “Preparing View Connection Server for Horizon Client,” on page 10

n “Install Horizon Client on Mac OS X,” on page 10

n “Add Horizon Client to Your Dock,” on page 11

n “Configuring Certificate Checking for End Users,” on page 11

n “Configure Advanced SSL Options,” on page 12

n “Configuring Log File Collection Values,” on page 13

n “Horizon Client Data Collected by VMware,” on page 13

System Requirements for Mac Clients
You can install Horizon Client for Mac OS X on all 64-bit Intel-based models that use the Mac OS X 10.6.8 or
later operating system.

The Mac on which you install Horizon Client, and the peripherals it uses, must meet certain system
requirements.

Model 64-bit Intel-based Mac

Memory At least 2GB of RAM

Operating systems n Mac OS X Snow Leopard (10.6.8)

n Mac OS X Lion (10.7)

n Mac OS X Mountain Lion (10.8)

n Mac OS X Mavericks (10.9)

n Mac OS X Yosemite (10.10)
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You must install Horizon Client on Mac OS X Mountain Lion (10.8) or later
to use remote applications. Remote applications do not appear in
Horizon Client if the client system is running an earlier version of OS X.

View Connection
Server, Security Server,
and View Agent

Latest maintenance release of View 5.3.x and later releases

If client systems connect from outside the corporate firewall, VMware
recommends that you use a security server. With a security server, client
systems will not require a VPN connection.

Remote applications are available only on Horizon 6.0 with View servers.

Display protocol for
View

PCoIP or RDP

Software Requirements
for RDP

Remote Desktop Connection Client for Mac from Microsoft, versions 2.0
through 2.1.1. You can download this client from the Microsoft Web site.

NOTE   Horizon Client for Mac OS X does not work with Microsoft Remote
Desktop 8.0 and later releases.

Smart cards See “Smart Card Authentication Requirements,” on page 9.

System Requirements for Real-Time Audio-Video
Real-Time Audio-Video works with standard webcam, USB audio, and analog audio devices, and with
standard conferencing applications like Skype, WebEx, and Google Hangouts. To support Real-Time Audio-
Video, your View deployment must meet certain software and hardware requirements.

View remote desktop The desktops must have View Agent 5.2 or later installed. For View Agent
5.2 or 5.3 desktops, the desktops must also have the corresponding Remote
Experience Agent installed. For example, if View Agent 5.3 is installed, you
must also install the Remote Experience Agent from View 5.3 Feature Pack 1.
See the View Feature Pack Installation and Administration document for View. If
you have View Agent 6.0 or later, no feature pack is required. Real-Time
Audio-Video is not supported in remote applications.

Horizon Client computer
or client access device

n Real-Time Audio-Video is supported on Mac OS X Mountain Lion (10.8)
and later. It is disabled on all earlier Mac OS X operating systems.

n The webcam and audio device drivers must be installed, and the
webcam and audio device must be operable, on the client computer. To
support Real-Time Audio-Video, you do not have to install the device
drivers on the desktop operating system where View Agent is installed.

Display protocol for
View

PCoIP

Real-Time Audio-Video is not supported in RDP desktop sessions.

Using VMware Horizon Client for Mac OS X

8  VMware, Inc.



Smart Card Authentication Requirements
Client systems that use a smart card for user authentication must meet certain requirements.

Horizon Client for Mac OS X supports using smart cards with remote desktops that have Windows XP,
Windows Vista, Windows 7, and Windows Server 2008 R2 guest operating systems. On the client system,
VMware recommends using a Mac OS X Mavericks (10.9) or later operating system. The following smart
cards were tested:

n U.S. Department of Defense Common Access Card (CAC)

n U.S. Federal Government Personal Identity Verification (PIV), also called FIPS-201

Each client system that uses a smart card for user authentication must have the following software and
hardware:

n Horizon Client

n A compatible smart card reader

n Product-specific application drivers

You must also install product-specific application drivers on the remote desktops. For Windows 7 remote
desktops, the operating system installs the related driver when you insert a smart card reader and PIV card.
For Windows XP and Windows Vista remote desktops, you can install the related driver by using
ActivIdentify ActivClient. You cannot use smart card authentication with RDS desktops.

Users who authenticate with smart cards must have a smart card and each smart card must contain a user
certificate. When you generate a certificate for a blank PIV card, enter the path to the server truststore file on
the View Connection Server or security server host on the Crypto Provider tab in the PIV Data Generator
tool. For information about creating a server truststore file, see "Configure Smart Card Authentication" in
the View Administration document.

In addition to meeting these requirements for Horizon Client systems, other View components must meet
certain configuration requirements to support smart cards:

n For information about configuring View servers to support smart card use, see the topic "Configure
Smart Card Authentication," in the View Administration document.

NOTE   Smart cards are supported only with View 5.3.2 or later servers and desktops.

n For information about tasks you might need to perform in Active Directory to implement smart card
authentication, see the topics about preparing Active Directory for smart card authentication, in the
View Installation document.

Supported Desktop Operating Systems
Administrators create virtual machines with a guest operating system and install View Agent in the guest
operating system. End users can log in to these virtual machines from a client device.

For a list of the supported guest operating systems, see the "Supported Operating Systems for View Agent"
topic in the View 5.x or 6.x installation documentation.

Chapter 1 Setup and Installation
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Preparing View Connection Server for Horizon Client
Administrators must perform specific tasks to enable end users to connect to remote desktops and
applications.

Before end users can connect to View Connection Server or a security server and access a remote desktop or
application, you must configure certain pool settings and security settings:

n If you are using a security server, as VMware recommends, verify that you are using the latest
maintenance releases of View Connection Server 5.3.x and View Security Server 5.3.x or later releases.
See the View Installation document.

n If you plan to use a secure tunnel connection for client devices and if the secure connection is
configured with a DNS host name for View Connection Server or a security server, verify that the client
device can resolve this DNS name.

To enable or disable the secure tunnel, in View Administrator, go to the Edit View Connection Server
Settings dialog box and use the check box called Use secure tunnel connection to desktop.

n Verify that a desktop or application pool has been created and that the user account that you plan to use
is entitled to access the pool. For View Connection Server 5.3 and earlier, see the topics about creating
desktop pools in the View Administration document. For View Connection Server 6.0 and later, see the
topics about creating desktop and application pools in the Setting Up Desktop and Application Pools in
View document.

IMPORTANT   If end users have a Retina display and will use the High Resolution Mode client setting
while viewing their remote desktops in full screen mode, you must allocate sufficient VRAM for each
Windows 7 or later remote desktop. The amount of vRAM depends on the number of monitors
configured for end users and on the display resolution. To estimate the amount of vRAM you need, see
the section "RAM Sizing for Specific Monitor Configurations When Using PCoIP" of the topic
"Estimating Memory Requirements for Virtual Desktops," in the View Architecture Planning document.

n To use two-factor authentication with Horizon Client, such as RSA SecurID or RADIUS authentication,
you must enable this feature on View Connection Server. RADIUS authentication is available with View
5.1 or later View Connection Server. For more information, see the topics about two-factor
authentication in the View Administration document.

Install Horizon Client on Mac OS X
End users open Horizon Client to connect to remote desktops and applications from a Mac OS X physical
machine. You install Horizon Client on Mac OS X client systems from a disk image file.

Prerequisites

n Verify that the client system uses a supported operating system. See “System Requirements for Mac
Clients,” on page 7.

n Verify that you can log in as an administrator on the client system.

n If you plan to use the RDP display protocol to connect to a remote desktop, verify that the Mac client
system has Remote Desktop Connection Client for Mac from Microsoft, version 2.0 or later installed.

n Verify that you have the URL for a download page that contains the Horizon Client installer. This URL
might be the VMware Downloads page at http://www.vmware.com/go/viewclients, or it might be the
URL for a View Connection Server instance.

When you browse to a View Connection Server URL, by default the links on that portal page point to
the VMware Downloads page. You can configure the links to point to a different location. For more
information, see GUID-B98D12E7-2B72-4AF3-B87E-3342F6C5EC68#GUID-B98D12E7-2B72-4AF3-
B87E-3342F6C5EC68. Depending on how the page is configured, you might also see a link for

Using VMware Horizon Client for Mac OS X
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HTML Access. HTML Access allows you to connect to a remote desktop or application by using the
browser, without installing any client software. Because VMware Horizon Client offers more features
and better performance than the HTML Access client, VMware generally recommends that you install
the client software.

Procedure

1 From your Mac, browse to the URL for downloading the Horizon Client installer file.

For Horizon Client 3.0, the file name format is VMware-Horizon-View-Client-y.y.y-xxxxxx.dmg. For
Horizon Client 3.1 and later, the file name format is VMware-Horizon-Client-y.y.y-xxxxxx.dmg. xxxxxx
is the build number and y.y.y is the version number.

2 Double-click the .dmg file to open it and click Agree.

The contents of the disk image appear in a Horizon Client Finder window.

3 In the Finder window, drag the VMware Horizon View Client (Horizon Client 3.0) or VMware
Horizon Client (Horizon Client 3.1 and later) icon to the Applications folder icon.

If you are not logged in as an administrator user, you are prompted for an administrator user name and
password.

What to do next

Start Horizon Client and verify that you can connect to a remote desktop or application. See “Connect to a
Remote Desktop or Application for the First Time,” on page 23.

Add Horizon Client to Your Dock
You can add Horizon Client to your Dock just as you do with any other application.

Procedure

1 In the Applications folder, select VMware Horizon View Client (Horizon Client 3.0) or VMware
Horizon Client (Horizon Client 3.1 and later).

2 Drag the VMware Horizon View Client (Horizon Client 3.0) or VMware Horizon Client (
Horizon Client 3.1 and later) icon to the Dock.

3 To configure the Dock icon to open Horizon Client at login or to show the icon in the Finder, right-click
the icon on the Dock, select Options, and select the appropriate command from the context menu.

When you quit Horizon Client, the application shortcut remains in the Dock.

Configuring Certificate Checking for End Users
Administrators can configure the certificate verification mode so that, for example, full verification is always
performed.

Certificate checking occurs for SSL connections between View Connection Server and Horizon Client.
Administrators can configure the verification mode to use one of the following strategies:

n End users are allowed to choose the verification mode. The rest of this list describes the three
verification modes.

n (No verification) No certificate checks are performed.

n (Warn) End users are warned if a self-signed certificate is being presented by the server. Users can
choose whether or not to allow this type of connection.

n (Full security) Full verification is performed and connections that do not pass full verification are
rejected.

Chapter 1 Setup and Installation
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For details about the types of verification checks performed, see “Certificate Checking Modes for Horizon
Client,” on page 28.

You can set the verification mode so that end users cannot change it. Set the "Security Mode" key in
the /Library/Preferences/com.vmware.view.plist (Horizon Client 3.0)
or /Library/Preferences/com.vmware.horizon.plist (Horizon Client 3.1 and later) file on Mac clients to one
of the following values:

n 1 implements Never connect to untrusted servers.

n 2 implements Warn before connecting to untrusted servers.

n 3 implements Do not verify server identity certificates.

Configure Advanced SSL Options
You can select the security protocols that Horizon Client can use. You can also specify the cipher control
string.

The advanced SSL options that you configure in Horizon Client are used to encrypt communications
between Horizon Client and View Connection Server and View Agent. In Horizon Client 3.1 and later, these
options are also used to encrypt the USB channel (communication between the USB service daemon and
View Agent).

IMPORTANT   If the only protocol you enable on the client is TLS v1.1, you must verify that TLS v1.1 is also
enabled on the remote desktop. Otherwise, USB devices cannot be redirected to the remote desktop.

Prerequisites

Verify the security protocol that the View server can use. If you configure a security protocol for
Horizon Client that is not enabled on the View server to which the client connects, an SSL error occurs and
the connection fails. For information about configuring the security protocols that are accepted by View
Connection Server instances, see the View Security document.

Horizon Client and View Connection Server support TLS v1.0 and TLS v1.1 by default. You should change
the security protocols in Horizon Client only if your View administrator instructs you to do so, or if your
View server does not support the current settings.

Procedure

1 Select VMware Horizon View Client > Preferences (Horizon Client 3.0) or VMware Horizon Client >
Preferences (Horizon Client 3.1 and later) from the menu bar and click Advanced in the Preferences
dialog box.

2 To enable or disable a security protocol, select the check box next to the security protocol name.

TLSv1.0 and TLSv1.1 are enabled by default.

3 To change the cipher control string, replace the default string in the text box.

The default cipher control string (AES:!aNULL:@STRENGTH) includes cipher suites that use either 128-
bit or 256-bit AES encryption, except for anonymous DH algorithms, and sorts them by strength.

NOTE   In Horizon Client 3.1 and later, the USB service daemon adds RC4 (:RC4-SHA: +RC4) to the end
of the cipher control string when it connects to a remote desktop.

4 (Optional) If you need to revert to the default settings, click Restore Defaults.

5 Click Confirm to save your changes.

Your changes take effect the next time you connect to View Connection Server.

Using VMware Horizon Client for Mac OS X
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Configuring Log File Collection Values
In Horizon Client 3.1 and later, Horizon Client generates log files in the ~/Library/Logs/VMware Horizon
Client directory on the Mac client. Administrators can configure the maximum number of log files and the
maximum number of days to keep log files by setting keys in
the /Library/Preferences/com.vmware.horizon.plist file on a Mac client.

Table 1‑1.  plist Keys for Log File Collection

Key Description

MaxDebugLogs Maximum number of log files. The maximum value is 100.

MaxDaysToKeepLogs Maximum number of days to keep log files. This value has no limit.

Files that do not match these criteria are deleted when you launch Horizon Client.

If the MaxDebugLogs or MaxDaysToKeepLogs keys are not set in the com.vmware.horizon.plist file, the
default number of log files is 5 and the default number of days to keep log files is 7.

Horizon Client Data Collected by VMware
If your company participates in the customer experience improvement program, VMware collects data from
certain Horizon Client fields. Fields containing sensitive information are made anonymous.

NOTE   This feature is available only if your View deployment uses View Connection Server 5.1 or later.

VMware collects data on the clients to prioritize hardware and software compatibility. If your company's
administrator has opted to participate in the customer experience improvement program, VMware collects
anonymous data about your deployment in order to improve VMware's response to customer requirements.
No data that identifies your organization is collected. Horizon Client information is sent first to View
Connection Server and then on to VMware, along with data from View servers, desktop pools, and remote
desktops.

Although the information is encrypted while in transit to View Connection Server, the information on the
client system is logged unencrypted in a user-specific directory. The logs do not contain any personally
identifiable information.

The administrator who installs View Connection Server can select whether to participate in the VMware
customer experience improvement program while running the View Connection Server installation wizard,
or an administrator can set an option in View Administrator after the installation.

Table 1‑2.  Data Collected from Horizon Clients for the Customer Experience Improvement Program

Description

Is This Field
Made
Anonymous
? Example Value

Company that produced the
Horizon Client application

No VMware

Product name No VMware Horizon Client

Client product version No (The format is x.x.x-yyyyyy, where x.x.x is the client version
number and yyyyyy is the build number.)

Client binary architecture No Examples include the following:
n i386
n x86_64
n arm

Chapter 1 Setup and Installation
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Table 1‑2.  Data Collected from Horizon Clients for the Customer Experience Improvement Program
(Continued)

Description

Is This Field
Made
Anonymous
? Example Value

Client build name No Examples include the following:
n VMware-Horizon-Client-Win32-Windows
n VMware-Horizon-Client-Linux
n VMware-Horizon-Client-iOS
n VMware-Horizon-Client-Mac
n VMware-Horizon-Client-Android
n VMware-Horizon-Client-WinStore

Host operating system No Examples include the following:
n Windows 8.1
n Windows 7, 64-bit Service Pack 1 (Build 7601 )
n iPhone OS 5.1.1 (9B206)
n Ubuntu 10.04.4 LTS
n Mac OS X 10.8.5 (12F45)

Host operating system kernel No Examples include the following:
n Windows 6.1.7601 SP1
n Darwin Kernel Version 11.0.0: Sun Apr 8 21:52:26 PDT

2012; root:xnu-1878.11.10~1/RELEASE_ARM_S5L8945X
n Darwin 11.4.2
n Linux 2.6.32-44-generic #98-Ubuntu SMP Mon Sep 24

17:27:10 UTC 2012
n unknown (for Windows Store)

Host operating system architecture No Examples include the following:
n x86_64
n i386
n armv71
n ARM

Host system model No Examples include the following:
n Dell Inc. OptiPlex 960
n iPad3,3
n MacBookPro8,2
n Dell Inc. Precision WorkStation T3400 (A04 03/21/2008)

Host system CPU No Examples include the following:
n Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GH
n Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GH
n unknown (for iPad)

Number of cores in the host system's
processor

No For example: 4

MB of memory on the host system No Examples include the following:
n 4096
n unknown (for Windows Store)

Number of USB devices connected No 2 (USB device redirection is supported only for Linux,
Windows, and Mac OS X clients.)

Maximum concurrent USB device
connections

No 2

Using VMware Horizon Client for Mac OS X
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Table 1‑2.  Data Collected from Horizon Clients for the Customer Experience Improvement Program
(Continued)

Description

Is This Field
Made
Anonymous
? Example Value

USB device vendor ID No Examples include the following:
n Kingston
n NEC
n Nokia
n Wacom

USB device product ID No Examples include the following:
n DataTraveler
n Gamepad
n Storage Drive
n Wireless Mouse

USB device family No Examples include the following:
n Security
n Human Interface Device
n Imaging

USB device usage count No (Number of times the device was shared)

Chapter 1 Setup and Installation
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Using URIs to Configure
Horizon Client 2

Using uniform resource identifiers (URIs), you can create a Web page or an email with links that end users
click to launch Horizon Client, connect to View Connection Server, and launch a specific desktop or
application with specific configuration options.

You can simplify the process of connecting to a remote desktop or application by creating Web or email
links for end users. You create these links by constructing URIs that provide some or all of the following
information, so that your end users do not need to supply it:

n View Connection Server address

n Port number for View Connection Server

n Active Directory user name

n Domain name

n Desktop or application display name

n Window size

n Actions including reset, log off, and start session

n Display protocol

n Options for redirecting USB devices

To construct a URI, you use the vmware-view URI scheme with Horizon Client specific path and query parts.

NOTE   You can use URIs to launch Horizon Client only if the client software is already installed on end
users' client computers.

This chapter includes the following topics:

n “Syntax for Creating vmware-view URIs,” on page 17

n “Examples of vmware-view URIs,” on page 20

Syntax for Creating vmware-view URIs
Syntax includes the vmware-view URI scheme, a path part to specify the desktop or application, and,
optionally, a query to specify desktop or application actions or configuration options.

URI Specification
Use the following syntax to create URIs for launching Horizon Client:

vmware-view://[authority-part][/path-part][?query-part]

VMware, Inc.  17



The only required element is the URI scheme, vmware-view. For some versions of some client operating
systems, the scheme name is case-sensitive. Therefore, use vmware-view.

IMPORTANT   In all parts, non-ASCII characters must first be encoded according to UTF-8 [STD63], and then
each octet of the corresponding UTF-8 sequence must be percent-encoded to be represented as URI
characters.

For information about encoding for ASCII characters, see the URL encoding reference at 
http://www.utf8-chartable.de/.

authority-part Specifies the server address and, optionally, a user name, a non-default port
number, or both. Note that underscores (_) are not supported in server
names. Server names must conform to DNS syntax.

To specify a user name, use the following syntax:

user1@server-address

Note that you cannot specify a UPN address, which includes the domain. To
specify the domain, you can use the domainName query part in the URI.

To specify a port number, use the following syntax:

server-address:port-number

path-part Specifies the desktop or application. Use the desktop display name or
application display name. This name is the one specified in View
Administrator when the desktop or application pool was created. If the
display name has a space in it, use the %20 encoding mechanism to represent
the space.

query-part Specifies the configuration options to use or the desktop or application
actions to perform. Queries are not case-sensitive. To use multiple queries,
use an ampersand (&) between the queries. If queries conflict with each
other, the last query in the list is used. Use the following syntax:

query1=value1[&query2=value2...]

Supported Queries
This topic lists the queries that are supported for this type of Horizon Client. If you are creating URIs for
multiple types of clients, such as desktop clients and mobile clients, see the Using VMware Horizon Client
guide for each type of client system.

action Table 2‑1.  Values That Can Be Used with the action Query

Value Description

browse Displays a list of available desktops and applications hosted on the
specified server. You are not required to specify a desktop or
application when using this action.
If you use the browse action and specify a desktop or application,
the desktop or application is highlighted in the list of available
items.

start-session Launches the specified desktop or application. If no action query is
provided and the desktop or application name is provided,
start-session is the default action.

Using VMware Horizon Client for Mac OS X
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Table 2‑1.  Values That Can Be Used with the action Query (Continued)

Value Description

reset Shuts down and restarts the specified desktop or remote
application. Unsaved data is lost. Resetting a remote desktop is the
equivalent of pressing the Reset button on a physical PC. In
Horizon Client 3.0, if you specify an application, the action will be
ignored.

logoff Logs the user out of the guest operating system in the remote
desktop. If you specify an application, the action will be ignored or
the end user will see the warning message "Invalid URI action."

connectUSBOnInsert Connects a USB device to the foreground virtual desktop when you plug in
the device. This query is implicitly set if you specify the unattended query.
To use this query, you must set the action query to start-session or else not
have an action query. Valid values are true and false. An example of the
syntax is connectUSBOnInsert=true.

connectUSBOnStartup (For Horizon Client 1.7 and later) Redirects all USB devices that are currently
connected to the client system to the desktop. This query is implicitly set if
you specify the unattended query. To use this query, you must set the action
query to start-session or else not have an action query. Valid values are
true and false. An example of the syntax is connectUSBOnStartup=true.

desktopLayout Sets the size of the window that displays a remote desktop. To use this
query, you must set the action query to start-session or else not have an
action query.

Table 2‑2.  Valid Values for the desktopLayout Query

Value Description

fullscreen Full screen on all connected external monitors. This is the
default.

windowLarge Large window.

windowSmall Small window.

WxH Custom resolution, where you specify the width by height,
in pixels. An example of the syntax is
desktopLayout=1280x800.

desktopProtocol For remote desktops, valid values are RDP and PCoIP. For example, to specify
PCoIP, use the syntax desktopProtocol=PCoIP. For remote applications,
regardless of the setting, the application sessions use PCoIP.

domainName The domain associated with the user who is connecting to the remote
desktop or application.

Chapter 2 Using URIs to Configure Horizon Client
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Examples of vmware-view URIs
You can create hypertext links or buttons with the vmware-view URI scheme and include these links in email
or on a Web page. Your end users can click these links to, for example, launch a particular remote desktop
with the startup options you specify.

URI Syntax Examples
Each URI example is followed by a description of what the end user sees after clicking the URI link.

1 vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session

Horizon Client is launched and connects to the view.mycompany.com server. The login box prompts the
user for a user name, domain name, and password. After a successful login, the client connects to the
desktop whose display name is displayed as Primary Desktop, and the user is logged in to the guest
operating system.

NOTE   The default display protocol and window size are used. The default display protocol is PCoIP.
The default window size is full screen.

2 vmware-view://view.mycompany.com:7555/Primary%20Desktop

This URI has the same effect as the previous example, except that it uses the nondefault port of 7555 for
View Connection Server. (The default port is 443.) Because a desktop identifier is provided, the desktop
is launched even though the start-session action is not included in the URI.

3 vmware-view://fred@view.mycompany.com/Finance%20Desktop?desktopProtocol=PCoIP

Horizon Client is launched and connects to the view.mycompany.com server. In the login box, the User
name text box is populated with the name fred. The user must supply the domain name and password.
After a successful login, the client connects to the desktop whose display name is displayed as Finance
Desktop, and the user is logged in to the guest operating system. The connection uses the PCoIP
display protocol.

4 vmware-view://fred@view.mycompany.com/Finance%20Desktop?domainName=mycompany

Horizon Client is launched and connects to the view.mycompany.com server. In the login box, the User
name text box is populated with the name fred, and the Domain text box is populated with
mycompany. The user must supply only a password. After a successful login, the client connects to the
desktop whose display name is displayed as Finance Desktop, and the user is logged in to the guest
operating system.

5 vmware-view://view.mycompany.com/

Horizon Client is launched, and the user is taken to the login prompt for connecting to the
view.mycompany.com server.

6 vmware-view://view.mycompany.com/Primary%20Desktop?action=reset

Horizon Client is launched and connects to the view.mycompany.com server. The login box prompts the
user for a user name, domain name, and password. After a successful login, Horizon Client displays a
dialog box that prompts the user to confirm the reset operation for Primary Desktop. After the reset
occurs, depending on the type of client, the user might see a message indicating whether the reset was
successful.

NOTE   This action is available only if the View administrator has enabled this feature for end users.

7 vmware-view://

Horizon Client is launched, and the user is taken to the page for entering the address of a View
Connection Server instance.
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HTML Code Examples
You can use URIs to make hypertext links and buttons to include in emails or on Web pages. The following
examples show how to use the URI from the first URI example to code a hypertext link that says, Test Link,
and a button that says, TestButton.

<html>

<body>

<a href="vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session">Test 

Link</a><br>

<form><input type="button" value="TestButton" onClick="window.location.href=

'vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session'"></form> <br>

</body>

</html>
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Managing Remote Desktop and
Application Connections 3

Use Horizon Client to connect to View Connection Server or a security server and log in to or off of a remote
desktop, and use remote applications. For troubleshooting purposes, you can also reset remote desktops and
applications.

Depending on how the administrator configures policies for remote desktops, end users might be able to
perform many operations on their desktops.

This chapter includes the following topics:

n “Connect to a Remote Desktop or Application for the First Time,” on page 23

n “Hide the VMware Horizon Client Window,” on page 25

n “Configure Horizon Client to Select a Smart Card Certificate,” on page 26

n “Configure Keyboard Shortcut Mappings,” on page 26

n “Certificate Checking Modes for Horizon Client,” on page 28

n “Searching for Desktops or Applications,” on page 29

n “Select a Favorite Remote Desktop or Application,” on page 29

n “Switch Desktops or Applications,” on page 30

n “Log Off or Disconnect,” on page 31

n “Connecting to a View Server at Horizon Client Launch,” on page 32

n “Autoconnect to a Remote Desktop,” on page 32

n “Configure Reconnect Behavior for Remote Applications,” on page 33

n “Removing a View Server Shortcut from the Home Screen,” on page 33

n “Reordering Shortcuts,” on page 33

n “Roll Back a Desktop,” on page 34

Connect to a Remote Desktop or Application for the First Time
Before you have end users access remote desktops and applications, test that you can connect to remote
desktop or application from the client system.

To use remote applications, you must connect to View Connection Server 6.0 or later.
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Prerequisites

n Obtain the credentials you need to log in, such as a user name and password, RSA SecurID user name
and passcode, RADIUS authentication user name and passcode, or smart card personal identification
number (PIN).

n Obtain the domain name for logging in.

n Perform the administrative tasks described in “Preparing View Connection Server for Horizon Client,”
on page 10.

n If you are outside the corporate network and are not using a security server to access the remote
desktop, verify that your client device is set up to use a VPN connection and turn that connection on.

IMPORTANT   VMware recommends using a security server rather than a VPN.

n Verify that you have the fully qualified domain name (FQDN) of the server that provides access to the
remote desktop or application. Note that underscores (_) are not supported in server names. You also
need the port number if the port is not 443.

n If you plan to use the RDP display protocol to connect to a remote desktop, verify that the
AllowDirectRDP View Agent group policy setting is enabled.

n If your administrator has allowed it, you can configure the certificate checking mode for the SSL
certificate that the View server presents. See “Certificate Checking Modes for Horizon Client,” on
page 28.

n If you are using smart card authentication, you can configure Horizon Client to automatically use a
local certificate or the certificate on your smart card. See “Configure Horizon Client to Select a Smart
Card Certificate,” on page 26.

n If end users are allowed to use the Microsoft RDP display protocol, verify that the client system has
Remote Desktop Connection Client for Mac from Microsoft, version 2.0 or later. You can download this
client from the Microsoft Web site.

Procedure

1 In the Applications folder, double-click VMware Horizon View Client (Horizon Client 3.0) or
VMware Horizon Client (Horizon Client 3.1 and later).

2 Click Continue to start remote desktop USB and printing services, or click Cancel to use Horizon Client
without remote desktop USB and printing services.

If you click Continue, you must provide system credentials. If you click Cancel, you can enable remote
desktop USB and printing services later.

NOTE   The prompt to start remote desktop USB and printing services appears the first time you launch
Horizon Client. It does not appear again, regardless of whether you click Cancel or Continue.

3 Click the Add Server (Horizon Client 3.0) or New Server (Horizon Client 3.1 and later) icon on the
Horizon Client Home screen.

4 Type the server name and a port number if required, and click Continue (Horizon Client 3.0) or
Connect (Horizon Client 3.1 and later).

An example using a nondefault port is view.company.com:1443.

5 If you are prompted for RSA SecurID credentials or RADIUS authentication credentials, type the user
name and passcode and click Login.

6 Enter your user name and password, select a domain, and click Login.

You might see a message that you must confirm before the login dialog box appears.
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7 If the desktop security indicator turns red and a warning message appears, respond to the prompt.

Usually, this warning means that View Connection Server did not send a certificate thumbprint to the
client. The thumbprint is a hash of the certificate public key and is used as an abbreviation of the public
key. View Connection Server 5.0.1 and later versions send thumbprint information, but earlier versions
do not.

8 (Optional) If you are connecting to a remote desktop, select the display protocol to use.

The default display protocol is PCoIP. To use Microsoft RDP instead, select the desktop name, press
Control-click on the Apple keyboard, and select RDP.

9 Double-click a remote desktop or application to connect.

If you are connecting to a session-based remote desktop, which is hosted on a Microsoft RDS host, and
if the desktop is already set to use a different display protocol, you will not be able to connect
immediately. You will be prompted to either use the protocol that is currently set or have the system
log you off of the remote operating system so that a connection can be made with the protocol you
selected.

NOTE   In Horizon Client 3.2, if you are entitled to only one remote desktop on the View server,
Horizon Client automatically connects you to that desktop.

After you are connected, the client window appears. If Horizon Client cannot connect to the remote desktop
or application, perform the following tasks:

n Determine whether View Connection Server is configured not to use SSL. Horizon Client requires SSL
connections. Check whether the global setting in View Administrator for the Use SSL for client
connections check box is deselected. If so, you must either select the check box, so that SSL is used, or
set up your environment so that clients can connect to an HTTPS enabled load balancer or other
intermediate device that is configured to make an HTTP connection to View Connection Server.

n Verify that the security certificate for View Connection Server is working properly. If it is not, in View
Administrator, you might also see that the View Agent on desktops is unreachable.

n Verify that the tags set on the View Connection Server instance allow connections from this user. See
the View Administration document.

n Verify that the user is entitled to access the desktop or application. See the Setting Up Desktop and
Application Pools in View document.

n If you are using the RDP display protocol to connect to a remote desktop, verify that the client
computer allows remote desktop connections.

Hide the VMware Horizon Client Window
You can hide the VMware Horizon Client window after you launch a remote desktop or application.

In Horizon Client 3.1 or later, you can hide the VMware Horizon Client window after you launch a remote
desktop or application. You can also set a preference to always hide the VMware Horizon Client window
after remote desktop or application launch.

Procedure

n To hide the VMware Horizon Client window after you launch a remote desktop or application, click the
Close button in the corner of the VMware Horizon Client window.

The VMware Horizon Client icon remains in the Dock.
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n To set a preference to always hide the VMware Horizon Client window after remote desktop or
application launch, perform these steps before you connect to a View server.

a Select VMware Horizon Client > Preferences from the menu bar and click General in the
Preferences dialog box.

b Select Hide client window after desktop/application launched.

c Close the Preferences dialog box.

Your changes take effect when the dialog box is closed.

n To show the VMware Horizon Client window after it has been hidden, select Window > Open
Selection Window from the menu bar, or right-click the VMware Horizon Client icon in the Dock and
select Show All Windows.

Configure Horizon Client to Select a Smart Card Certificate
In Horizon Client 3.2, you can configure Horizon Client to select a local certificate or the certificate on a
smart card when you authenticate to a View server by setting a preference. If this preference is not set (the
default), you must manually select a certificate.

Prerequisites

For this setting to take effect, smart card authentication must be configured on the View server and only one
certificate must be available on your client system or smart card. If you have multiple certificates,
Horizon Client always prompts you to select a certificate, regardless of how this preference is set.

Procedure

1 Before you connect to a View server, select VMware Horizon Client > Preferences from the menu bar.

2 Click General in the Preferences dialog box.

3 Select Automatically select certificate.

4 Close the Preferences dialog box.

Your changes take effect when the dialog box is closed.

Configure Keyboard Shortcut Mappings
In Horizon Client 3.2, you can customize how remote desktops and applications interpret Apple keyboard
shortcuts by configuring keyboard shortcut mappings. You can create different keyboard shortcut mappings
for remote desktops and remote applications.

When you create a keyboard mapping, you map an Apple keyboard shortcut to a Windows keyboard
shortcut or action. A keyboard shortcut consists of one or more key modifiers, such as Control and Shift, and
a key code. A key code can be any key on your keyboard, except for a modifier key. The available actions
depend on whether the mapping applies to remote desktops or remote applications. Examples of actions
include Toggle Fullscreen Mode, Quit Application, and Disabled. When you press a mapped keyboard
shortcut on your Apple keyboard, the corresponding Windows keyboard shortcut or action occurs in the
remote desktop or application.

Prerequisites

If you plan to map an operating system keyboard shortcut, see “Considerations for Mapping Operating
System Keyboard Shortcuts,” on page 28.

Procedure

1 Select VMware Horizon Client > Preferences and click Keyboard.
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2 Click the Desktop tab to configure keyboard shortcut mappings for remote desktops, or click the
Applications tab to configure keyboard shortcut mappings for remote applications.

3 Configure the keyboard shortcut mappings.

Option Action

Delete a keyboard shortcut
mapping

Select the mapping and click the minus (-) button.

Add a keyboard shortcut mapping a Click the plus (+) button.
b Specify the Apple keyboard shortcut sequence by clicking one or more

keyboard modifiers and typing a key code in the text box. You can also
select a key from the drop-down menu. The From: field shows the
keyboard shortcut that you created.

c Specify the corresponding Windows keyboard shortcut sequence by
clicking one or more keyboard modifiers and typing a key code in the
text box. You can also select a key from the drop-down menu. The To:
field shows the keyboard shortcut that you created.

d Click OK to save your changes.

Modify a keyboard shortcut
mapping

Double-click the mapping and make your changes.
n To modify the Apple keyboard shortcut sequence, click one or more

keyboard modifiers and typing a key code in the text box. You can also
select a key from the drop-down menu.

n To modify the corresponding Windows keyboard shortcut sequence,
click one or more keyboard modifiers and typing a key code in the text
box. You can also select a key from the drop-down menu.

n To add or modify an action, select Client action and select an action
from the drop-down menu.

Click OK to save your changes.

Map a keyboard shortcut to an
action

a Click the plus (+) button.
b Specify the Apple keyboard shortcut sequence by clicking one or more

keyboard modifiers and typing a key code in the text box. You can also
select a key from the drop-down menu. The From: field shows the
keyboard shortcut that you created.

c Select Client action and select an action from the drop-down menu.
d Click OK to save your changes.

Disable a keyboard shortcut
mapping

When you disable a keyboard shortcut mapping, Horizon Client does not
send the Apple keyboard shortcut to the remote desktop or application.
a Click the plus (+) button.
b Specify the Apple keyboard shortcut sequence by clicking one or more

keyboard modifiers and typing a key code in the text box. You can also
select a key from the drop-down menu.

The From: field shows the keyboard shortcut that you created.
c Select Client action and select Disabled from the drop-down menu.
d Click OK to save your changes.

Restore the default mappings Click Restore Defaults and click Restore. Any changes that you made to
the default keyboard shortcut mappings are deleted and the default
mappings are restored.

 
4 Close the Preferences dialog box.

Your keyboard mapping changes take effect immediately. You do not need to restart open remote
desktops or applications to see the changes take effect.
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Considerations for Mapping Operating System Keyboard Shortcuts
OS X and Windows both include default keyboard shortcuts. For example, Command-Tab and Command-
Space bar are common keyboard shortcuts on OS X systems and Ctrl+Esc and Alt+Enter are common
keyboard shortcuts on Windows systems. If you attempt to map one of these operating system keyboard
shortcuts in Horizon Client, the behavior of the shortcut on your Mac client system and in the remote
desktop or application can be unpredictable.

n If you map an OS X keyboard shortcut, how the shortcut behaves on your Mac client system depends
on how OS X manages the shortcut. For example, the keyboard shortcut might trigger an action in OS X
and Horizon Client might not respond to the shortcut. Alternatively, the keyboard shortcut might
trigger an action in both OS X and Horizon Client.

n Before you map an OS X keyboard shortcut in Horizon Client, you must disable the shortcut in System
Preferences on your Mac client system. Not all OS X keyboard shortcuts can be disabled.

n If you map a Windows keyboard shortcut in Horizon Client, the mapped action occurs when you use
the shortcut in the remote desktop or application.

n For remote applications, Windows shortcuts that include the Windows key are disabled by default and
do not appear on the Horizon Client Keyboard Preferences dialog box. If you create a mapping for one
of these disabled keyboard shortcuts, the shortcut appears in the Keyboard Preferences dialog box.

For a list of the default OS X keyboard shortcuts, go to the Apple support website (
http://support.apple.com). For a list of the default Windows shortcuts, go to the Microsoft Windows website
(http://windows.microsoft.com).

Certificate Checking Modes for Horizon Client
Administrators and sometimes end users can configure whether client connections are rejected if any or
some server certificate checks fail.

Certificate checking occurs for SSL connections between View Connection Server and Horizon Client.
Certificate verification includes the following checks:

n Is the certificate intended for a purpose other than verifying the identity of the sender and encrypting
server communications? That is, is it the correct type of certificate?

n Has the certificate expired, or is it valid only in the future? That is, is the certificate valid according to
the computer clock?

n Does the common name on the certificate match the host name of the server that sends it? A mismatch
can occur if a load balancer redirects Horizon Client to a server that has a certificate that does not match
the host name entered in Horizon Client. Another reason a mismatch can occur is if you enter an IP
address rather than a host name in the client.

n Is the certificate signed by an unknown or untrusted certificate authority (CA)? Self-signed certificates
are one type of untrusted CA.

To pass this check, the certificate's chain of trust must be rooted in the device's local certificate store.

NOTE   For instructions about distributing a self-signed root certificate and installing it on Mac OS X client
systems, see the Advanced Server Administration document for the Mac OS X Server you are using, available
from the Apple Web site.

In addition to presenting a server certificate, View Connection Server 5.0.1 and later versions also send a
certificate thumbprint to Horizon Client. The thumbprint is a hash of the certificate public key and is used as
an abbreviation of the public key. If the View server does not send a thumbprint, you see a warning that the
connection is untrusted.
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If your administrator has allowed it, you can set the certificate checking mode. Select VMware Horizon
View Client > Preferences (Horizon Client 3.0) or VMware Horizon Client > Preferences (Horizon Client
3.1 and later) from the menu bar. You have three choices:

n Never connect to untrusted servers. If any of the certificate checks fails, the client cannot connect to the
server. An error message lists the checks that failed.

n Warn before connecting to untrusted servers. If a certificate check fails because the server uses a self-
signed certificate, you can click Continue to ignore the warning. For self-signed certificates, the
certificate name is not required to match the View Connection Server name you entered in
Horizon Client.

n Do not verify server identity certificates. This setting means that View does not perform any certificate
checking.

If the certificate checking mode is set to Warn, you can still connect to a View Connection Server instance
that uses a self-signed certificate.

If an administrator later installs a security certificate from a trusted certificate authority, so that all certificate
checks pass when you connect, this trusted connection is remembered for that specific server. In the future,
if that server ever presents a self-signed certificate again, the connection fails. After a particular server
presents a fully verifiable certificate, it must always do so.

Searching for Desktops or Applications
After you connect to a View server, the available desktops and applications on that server appear on the
desktop and application selection window. You can search for a particular desktop or application by typing
in the window.

When you begin to type, Horizon Client highlights the first matching desktop or application name. To
connect to a highlighted desktop or application, press the Enter key. If you continue to type after the first
match is found, Horizon Client continues to search for matching desktops and applications. If
Horizon Client finds multiple matching desktops or applications, you can press the Tab key to switch to the
next match. If you stop typing for two seconds and then begin to type again, Horizon Client assumes that
you are starting a new search.

Select a Favorite Remote Desktop or Application
You can select remote desktops and applications as favorites. Favorites are identified by a star. The star
helps you quickly find your favorite desktops and applications. Your favorite selections are saved, even
after you log off from the server.

Prerequisites

Obtain the credentials you need to connect to the server, such as a user name and password or RSA SecurID
and passcode.

Procedure

1 On the Horizon Client Home screen, double-click the server icon.

2 If prompted, supply your RSA user name and passcode, your Active Directory user name and
password, or both.
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3 Perform these steps to select or deselect a desktop or application as a favorite.

Option Description

Select a favorite Select the desktop or application shortcut, press Control-click, and select
Mark as Favorite from the context menu. A star appears in the upper right
corner of the desktop or application shortcut.

Deselect a favorite Select the desktop or application shortcut, press Control-click, and deselect
Mark as Favorite from the context menu. A star no longer appears in the
upper right corner of the desktop or application shortcut.

 
4 (Optional) To display only favorite desktops or applications, click the Favorites button (star icon) in the

upper right corner of the desktop and application selection window.

You can click the Favorites button again to display all the available desktops and applications.

Switch Desktops or Applications
If you are connected to a remote desktop, you can switch to another desktop. You can also connect to remote
applications while you are connected to a remote desktop.

Procedure

u Select a remote desktop or application from the same server or a different server.

Option Action

Choose a different desktop or
application on the same server

Perform one of the following actions:
n To keep the current desktop and also connect to another remote

desktop, select Window > VMware Horizon View Client (
Horizon Client 3.0) or Window > VMware Horizon Client (
Horizon Client 3.1 and later) from the menu bar and double-click the
shortcut for the other desktop. That desktop opens in a new window
so that you have multiple desktops open. You can switch between
desktops from the Window menu on the menu bar.

n To close the current desktop and connect to another desktop, select
Connection > Disconnect from the menu bar and double-click the
shortcut for the other desktop.

n To open another application, double-click the shortcut for the other
application. That application opens in a new window. You can have
multiple applications open and you can switch between them by
clicking in an application window.

Choose a different desktop or
application on a different server

If you are entitled to multiple desktops or applications, so that the desktop
and application selection window is open, click the Disconnect from
Server button in the left side of the toolbar in the desktop and application
selection window and disconnect from the server. If you are entitled to
only one desktop or application, and the desktop and application selection
window is not open, you can select File > Disconnect from Server from
the menu bar and then connect to a different server.
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Log Off or Disconnect
If you disconnect from a remote desktop without logging off, applications in the desktop remain open. You
can also disconnect from a server and leave remote applications running.

Even if you do not have a remote desktop open, you can log off of the remote desktop operating system.
Using this feature has the same result as sending Ctrl+Alt+Del to the desktop and then clicking Log Off.

NOTE   The Windows key combination Ctrl+Alt+Del is not supported in remote desktops. To use the
equivalent of pressing Ctrl+Alt+Del, select Connection > Send Ctrl-Alt-Del from the menu bar.

Alternatively, you can press Fn-Control-Option-Delete on an Apple keyboard.

Procedure

n Disconnect from a remote desktop without logging off.

Option Action

Disconnect and quit Horizon Client Horizon Client 3.0 :
n Click the Close button in the corner of the window or select File >

Close from the menu bar.
Horizon Client 3.1 and later:
a Click the Close button in the corner of the window or select File >

Close from the menu bar.
b Select VMware Horizon Client > Quit VMware Horizon Client from

the menu bar.

Disconnect and remain in
Horizon Client

Click the Disconnect button in the toolbar or select Connection >
Disconnect from the menu bar.

 

NOTE   Your View administrator can configure your desktop to automatically log off when
disconnected. In that case, any open applications in your desktop are stopped.

n Log off and disconnect from a remote desktop.

Option Action

From within the desktop OS Use the Windows Start menu to log off.

From the menu bar Select Connection > Log Off from the menu bar.
If you use this procedure, files that are open on the remote desktop will be
closed without being saved first.

 

n Disconnect from a remote application.

Option Action

Disconnect from the server and
leave the application running

Perform one of the following actions:
n Click the Disconnect from Server button in the left side of the toolbar

in the desktop and application selection window.
n Select File > Disconnect from Server from the menu bar.

Close the application and
disconnect from the server

a Quit the application in the usual manner, for example, click the Close
button in the corner of the application window.

b Click the Disconnect from Server button in the left side of the toolbar
in the desktop and application selection window or select File >
Disconnect from Server from the menu bar.
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n Log off when you do not have a remote desktop open.

If you use this procedure, files that are open on the remote desktop will be closed without being saved
first.

Option Action

From the Home screen a Double-click the server shortcut and supply credentials.

These might include RSA SecurID credentials and credentials for
logging in to the desktop.

b Select the desktop and select Connection > Log Off from the menu
bar.

From the desktop and application
selection window

Select the desktop and select Connection > Log Off from the menu bar.

 

Connecting to a View Server at Horizon Client Launch
In Horizon Client 3.2, the Always connect at launch setting is enabled by default for the first View server
that you connect to with Horizon Client. When this setting is enabled for a View server, Horizon Client
always connects to that View server when you launch Horizon Client.

To disable this behavior for a View server, select the View server shortcut on the Horizon Client Home
screen, press Control-click on the Apple keyboard, and deselect the Always connect at launch setting. If you
have other View server shortcuts on your Horizon Client Home screen, you can enable the Always connect
at launch setting for a different server.

You can enable the Always connect at launch setting for only one View server at a time.

Autoconnect to a Remote Desktop
In Horizon Client 3.2, you can configure a View server to automatically launch a remote desktop when you
connect to the server.

If you are entitled to only one remote desktop on a View server, Horizon Client automatically launches that
desktop when you connect to the server.

NOTE   You cannot configure a View server to automatically launch a remote application.

Prerequisites

Obtain the credentials you need to connect to the server, such as a user name and password or RSA SecurID
user name and passcode.

Procedure

1 On the Horizon Client Home screen, double-click the server icon.

2 If prompted, supply your credentials.

3 Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4 Select a desktop pool in the left pane of the Settings dialog box.

5 Select Autoconnect to this desktop.

6 Click Continue to save your changes.

The next time you connect to the View server, Horizon Client automatically launches the remote desktop.
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Configure Reconnect Behavior for Remote Applications
If a user disconnects from a View server without closing a remote application, Horizon Client prompts the
user to reopen that application the next time the user connects to the server. You can change this behavior
by modifying the Reconnect Behavior setting in Horizon Client.

Prerequisites

Obtain the credentials you need to connect to the server, such as a user name and password or RSA SecurID
user name and passcode.

Procedure

1 On the Horizon Client Home screen, double-click the server icon.

2 If prompted, supply your credentials.

3 Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4 Select Applications in the left pane of the Settings dialog box.

5 Select an application reconnect behavior option.

These options determine how Horizon Client behaves when a user connects to the server and remote
applications are still running.

Option Description

Ask to reconnect to open
applications

Horizon Client shows the message You have one or more remote
applications running. Would you like to open them now? . Users can
respond by clicking Reconnect to Applications or Not Now. Users can
also select the Don't show this message again. check box to suppress the
message in the future. This setting is enabled by default.

Reconnect automatically to open
applications

Horizon Client immediately reopens any running applications.

Do not ask to reconnect and do not
automatically reconnect

Horizon Client does not prompt users to reopen running applications, nor
does it reopen running applications. This setting has the same effect as the
Don't show this message again. check box.

 
6 Click Continue to save your changes.

The new setting takes effect the next time a user connects to the server.

Removing a View Server Shortcut from the Home Screen
After you connect to a View server, a server shortcut is saved to the Horizon Client Home screen.

You can remove a View Connection Server shortcut by selecting the shortcut and pressing the Delete key or
by Control-clicking or right-clicking the shortcut on the Home screen and selecting Delete.

You cannot remove remote desktop or application shortcuts that appear after you connect to a server.

Reordering Shortcuts
You can reorder View server, remote desktop, and remote application shortcuts.

Each time you connect to a View server, Horizon Client saves a server shortcut to the Home screen. You can
reorder these View server shortcuts by selecting a shortcut and dragging it to a new position on the Home
screen.
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After you connect to a View server, the available desktops and applications on that server appear in the
desktop and application selection window. Desktop shortcuts appear first, followed by application
shortcuts. Desktop shortcuts and application shortcuts are arranged alphabetically and cannot be
rearranged. When you are in Favorites view (you clicked the Favorites button in the upper right corner of
the desktop and application selection window), you can reorder desktop and application shortcuts by
selecting a shortcut and dragging it to a new position on the window.

Roll Back a Desktop
Rolling back discards changes made to a remote desktop that you checked out for use in local mode on a
Windows PC or laptop.

You can roll back a remote desktop only if your View administrator has enabled this feature and only if you
checked out the desktop.

CAUTION   If changes were made to the local mode desktop and those changes were not replicated back to the
View server before rolling back, the changes are lost.

Prerequisites

n Back up the desktop to the server to preserve data or files.

You can use View Administrator to replicate data to the server, or, if the policy is set to allow it, you can
use View Client with Local Mode on the Windows client where the desktop is currently checked out.

Procedure

1 If the Horizon Client Home screen displays View Connection Server shortcuts, double-click the shortcut
for the server that accesses the desktop and supply credentials.

a If you are prompted for RSA SecurID credentials or RADIUS authentication credentials, enter the
user name and passcode and click Continue.

b Enter your user name and password in the login dialog box.

2 On the Horizon Client Home screen that displays remote desktop shortcuts, select the desktop and
select Connection > Rollback from the menu bar.

After the remote desktop is rolled back, you can log in to it from the Mac client.
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Using a Microsoft Windows Desktop
or Application on a Mac 4

Horizon Client for Mac OS X supports several features.

This chapter includes the following topics:

n “Feature Support Matrix for Mac OS X,” on page 35

n “Internationalization,” on page 37

n “Monitors and Screen Resolution,” on page 37

n “Connect USB Devices,” on page 38

n “Using the Real-Time Audio-Video Feature for Webcams and Microphones,” on page 45

n “Copying and Pasting Text and Images,” on page 49

n “Using Remote Applications,” on page 49

n “Saving Documents in a Remote Application,” on page 50

n “Printing from a Remote Desktop,” on page 50

n “PCoIP Client-Side Image Cache,” on page 52

Feature Support Matrix for Mac OS X
Some features are supported on one type of Horizon Client but not on another.

Table 4‑1.  Features Supported on Windows Desktops for Mac OS X Clients

Feature
Windows 8.x
Desktop

Windows 7
Desktop

Windows
Vista
Desktop

Windows XP
Desktop

Windows Server
2008 R2 Desktop

RSA SecurID or RADIUS X X X X X

Single sign-on X X X X X

PCoIP display protocol X X X X X

RDP display protocol X X X X X

USB access X X X X X

Real-Time Audio-Video
(RTAV)

X X X X X

Wyse MMR

Windows 7 MMR

Virtual printing X X X X X

Location-based printing X X X X X
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Table 4‑1.  Features Supported on Windows Desktops for Mac OS X Clients (Continued)

Feature
Windows 8.x
Desktop

Windows 7
Desktop

Windows
Vista
Desktop

Windows XP
Desktop

Windows Server
2008 R2 Desktop

Smart cards X X X X

Multiple monitors X X X X X

For descriptions of these features, see the View Planning document.

Feature Support for Session-Based Desktops on RDS Hosts
RDS hosts are server computers that have Windows Remote Desktop Services and View Agent installed.
Multiple users can have desktop sessions on an RDS host simultaneously. An RDS host can be either a
physical machine or a virtual machine.

NOTE   The following table contains rows only for the features that are supported, unlike the feature support
matrixes for single-user virtual machine desktops, because RDS host feature support is the same for all types
of clients.

Table 4‑2.  Features Supported for RDS Hosts with View Agent 6.0.x Installed

Feature

Windows Server
2008 R2 RDS Host
on a Physical
Machine

Windows Server
2008 R2 RDS Host
on a Virtual Machine

Windows Server
2012 RDS Host
on a Physical
Machine

Windows Server 2012
RDS Host on a Virtual
Machine

RSA SecurID or
RADIUS

X X X X

Single sign-on X X X X

RDP display protocol X X X X

PCoIP display
protocol

X X X X

BLAST protocol (for
HTML Access)

View Agent 6.0.2 and
later

View Agent 6.0.2 and
later

View Agent 6.0.2
and later

View Agent 6.0.2 and
later

Virtual printing View Agent 6.0.1 and
later

View Agent 6.0.1 and
later

Location-based
printing

View Agent 6.0.1 and
later

View Agent 6.0.1 and
later

Multiple monitors X X X X

Unity Touch (for
mobile clients)

X X X X

For information about which editions of each guest operating system are supported, or which service packs,
see the "Supported Operating Systems for View Agent" topic in the View 5.x or 6.x installation
documentation.

Limitations for Specific Features
Features that are supported on Windows desktops for Mac OS X Horizon Client have the following
restrictions.
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Table 4‑3.  Requirements for Specific Features

Feature Requirements

Windows 8.x desktop support View 5.2 or later servers and desktops.

Windows Server 2008 R2 desktop support View 5.3 or later servers and desktops.

RDP connection with a Windows 8.1 desktop See the VMware KB article at 
http://kb.vmware.com/kb/2059786.

Real-Time Audio-Video View 5.2 with Feature Pack 2 or later. For a complete list of
requirements, see “System Requirements for Real-Time
Audio-Video,” on page 8.

Virtual printing and location-based printing for Windows
Server 2008 R2 desktops, RDS desktops (on virtual machine
RDS hosts), and remote applications

Horizon Client 3.1 and later and Horizon 6.0.1 with View
and later servers.

Smart cards Horizon Client 3.2 or later. You cannot use smart cards
with RDS desktops.

NOTE   You can also use Horizon Client to securely access remote Windows-based applications, in addition
to remote desktops. Selecting an application in Horizon Client opens a window for that application on the
local client device, and the application looks and behaves as if it were locally installed.

You can use remote applications only if you are connected to View Connection Server 6.0 or later. For
information about which operating systems are supported for the RDS (Remote Desktop Sessions) host,
which provides remote applications and session-based desktops, see the View Architecture Planning
document.

Internationalization
The user interface and documentation are available in English, Japanese, French, German, Simplified
Chinese, Traditional Chinese, and Korean.

Monitors and Screen Resolution
When you use the PCoIP display protocol, you can extend a remote desktop to multiple monitors. If you
have a Mac with Retina Display, you can see the remote desktop in full resolution.

Using Multiple Monitors
If you use the PCoIP display protocol when accessing a remote desktop, you can use up to two monitors,
with a resolution of up to 2560x1600 per display. If you are using two monitors, the monitors can be side by
side or vertically stacked.

When the 3D rendering feature is enabled, the maximum resolution is 1920x1200. Examples of 3D
applications include Windows Aero themes, Microsoft Office 2010, and Google Earth.

To extend a remote desktop to multiple monitors you can use the Window > Full Screen menu item or the
expander arrows in the upper-right corner of the desktop window.

Using a High-Resolution Mac with Retina Display
When you use the PCoIP display protocol, Horizon Client also supports very high resolutions for those
client systems with Retina Display. After you connect to a remote desktop, you can choose the Connection >
Resolution > Full Resolution menu item. This menu item appears only if the client system supports Retina
Display.

If you use Full Resolution, the icons on the remote desktop are smaller but the display is sharper.
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Connect USB Devices
You can use locally attached USB devices, such as thumb flash drives, cameras, and printers, from a remote
desktop. This feature is called USB redirection.

When you use this feature, most USB devices that are attached to the local client system become available
from a menu in Horizon Client. You use the menu to connect and disconnect the devices.

Using USB devices with remote desktops has the following limitations:

n When you access a USB device from a menu in Horizon Client and use the device in a remote desktop,
you cannot access the device on the local computer.

n USB devices that do not appear in the menu, but are available in a remote desktop, include human
interface devices such as keyboards and pointing devices. The remote desktop and the local computer
use these devices at the same time. Interaction with these devices can sometimes be slow because of
network latency.

n Large USB disk drives can take several minutes to appear in the desktop.

n Some USB devices require specific drivers. If a required driver is not already installed on a remote
desktop, you might be prompted to install it when you connect the USB device to the remote desktop.

n If you plan to attach USB devices that use MTP drivers, such as Android-based Samsung smart phones
and tablets, you must set Horizon Client to automatically connect USB devices to your remote desktop.
Otherwise, if you try to manually redirect the USB device by using a menu item, the device will not be
redirected unless you unplug the device and then plug it in again.

n Webcams are not supported for USB redirection.

n The redirection of USB audio devices depends on the state of the network and is not reliable. Some
devices require a high data throughput even when they are idle.

You can connect USB devices to a remote desktop either manually or automatically.

NOTE   Do not redirect USB Ethernet connections to the remote desktop. Your remote desktop can connect to
your network if your local system is connected. If you have set your remote desktop to autoconnect USB
devices, you can add an exception to exclude your Ethernet connection. See “Configuring USB Redirection
on a Mac OS X Client,” on page 40 .

Prerequisites

n To use USB devices with a remote desktop, the View administrator must have enabled the USB feature
for the remote desktop.

This task includes installing the USB Redirection component of View Agent, and can include setting
group policies regarding USB redirection. For more information, see the View Administration document
if you are using Vew Connection Server and Agent 5.x or an earlier version. See Setting Up Desktop and
Application Pools in View if you are using View Connection Server and Agent 6.0 or later.

n If this is the first time you are attempting to connect a USB device, you must provide the Administrator
password. Horizon Client will prompt you when it is time to do so.

Some components required for USB redirection that are already installed by Horizon Client need to be
configured, and configuration of these components requires Administrator privileges.
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Procedure

n Manually connect the USB device to a remote desktop.

a If this is the first time you are using the USB feature, from the VMware Horizon Client menu bar,
click Connection > USB > Start remote desktop USB services and provide the Administrator
password when prompted.

b Connect the USB device to your local client system.

c From the VMware Horizon Client menu bar, click Connection > USB.

d Connect to a remote desktop to list the connected USB devices and select a USB device.

The device is manually redirected from the local system to the remote desktop.

n Configure Horizon Client to connect USB devices automatically to the remote desktop when you plug
them in to the local system.

If you plan to connect devices that use MTP drivers, such as Android-based Samsung smart phones and
tablets, be sure to use this autoconnect feature.

a Before you plug in the USB device, start Horizon Client and connect to a remote desktop.

b If this is the first time you are using the USB feature, from the VMware Horizon Client menu bar,
click Connection > USB > Start remote desktop USB services and provide the Administrator
password when prompted.

c From the VMware Horizon Client menu bar, click Connection > USB > Automatically connect
when inserted.

d Plug in the USB device.

USB devices that you connect to your local system after you start Horizon Client are redirected to the
remote desktop.

n Configure Horizon Client to connect USB devices automatically to the remote desktop when
Horizon Client starts.

a If this is the first time you are using the USB feature, from the VMware Horizon Client menu bar,
click Connection > USB > Start remote desktop USB services and provide the Administrator
password when prompted.

b From the VMware Horizon Client menu bar, click Connection > USB > Automatically connect at
startup.

c Plug in the USB device and restart Horizon Client.

USB devices that are connected to the local system when you start Horizon Client are redirected to the
remote desktop.

The USB device appears in the desktop. This might take up to 20 seconds. The first time you connect the
device to the desktop you might be prompted to install drivers.

If the USB device does not appear in the desktop after several minutes, disconnect and reconnect the device
to the client computer.

What to do next

If you have problems with USB redirection, see the topic about troubleshooting USB redirection problems in
the Setting Up Desktop and Application Pools in View document.
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Configuring USB Redirection on a Mac OS X Client
Administrators can configure the client system to specify which USB devices can be redirected to a remote
desktop.

You can configure USB policies for both View Agent, on the remote desktop, and Horizon Client, on the
local system, to achieve the following goals:

n Restrict the types of USB devices that Horizon Client makes available for redirection.

n Make View Agent prevent certain USB devices from being forwarded from a client computer.

n Specify whether Horizon Client should split composite USB devices into separate components for
redirection.

Composite USB devices consist of a combination of two or more devices, such as a video input device
and a storage device.

Configuration settings on the client might be merged with or overridden by corresponding policies set for
View Agent on the remote desktop. For information about how USB settings on the client work in
conjunction with View Agent USB policies, see the topics about using policies to control USB redirection, in
the View Administration document.

IMPORTANT   The USB filtering features and device splitting features described in these topics are available
with View Connection Server 5.1 and later.

Syntax for Configuring USB Redirection
You can configure filtering and splitting rules to exclude or include USB devices from being redirected to a
remote desktop. On a Mac OS X client, you configure USB functionality by using Terminal
(/Applications/Utilities/Terminal.app) and running a command as root.

n To list the rules:

# sudo defaults read domain

For example:

# sudo defaults read com.vmware.viewusb

n To remove a rule:

# sudo defaults delete domain property

For example:

# sudo defaults delete com.vmware.viewusb ExcludeVidPid

n To set or replace a filter rule:

# sudo defaults write domain property value

For example:

# sudo defaults write com.vmware.viewusb ExcludeVidPid vid-1234_pid-5678

IMPORTANT   Some configuration parameters require the VID (vendor ID) and PID (product ID) for a
USB device. To find the VID and PID, you can search on the Internet for the product name combined
with vid and pid. Alternatively, you can look in the USB Log file after you plug in the USB device to the
local system when Horizon Client is running. For more information, see “Turn on Logging for USB
Redirection,” on page 44.
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n To set or replace a splitting rule for a composite device:

# sudo defaults write domain property value

For example:

# sudo defaults write com.vmware.viewusb AllowAutoDeviceSplitting true

# sudo defaults write com.vmware.viewusb SplitExcludeVidPid vid-03f0_Pid-2a12

# sudo defaults write com.vmware.viewusb SplitVidPid "'vid-0911_Pid-149a(exintf:03)'"

# sudo defaults write com.vmware.viewusb IncludeVidPid vid-0911_Pid-149a

Composite USB devices consist of a combination of two or more devices, such as a video input device
and a storage device. The first line in this example turns on automatic splitting of composite devices.
The second line excludes the specified composite USB device (Vid-03f0_Pid-2a12) from splitting.

The third line tells Horizon Client to treat the components of a different composite device
(Vid-0911_Pid-149a) as separate devices but to exclude the following component from being redirected:
the component whose interface number is 03. This component is kept local.

Because this composite device includes a component that is ordinarily excluded by default, such as a
mouse or keyboard, the fourth line is necessary so that the other components of the composite device
Vid-0911_Pid-149a can be redirected to the remote desktop.

The first three properties are splitting properties. The last property is a filtering property. Filtering
properties are processed before splitting properties.

Example: Excluding a USB Ethernet Device
One example of a USB device you might want to exclude from redirection is a USB Ethernet device. Suppose
that your Mac is using a USB Ethernet device to connect the network for the Mac client system to a remote
desktop. If you redirect the USB Ethernet device, your local client system will lose its connection to the
network and the remote desktop.

If you want to permanently hide this device from the USB connection menu, or if you have set your remote
desktop to autoconnect USB devices, you can add an exception to exclude your Ethernet connection.

sudo defaults write com.vmware.viewusb ExcludeVidPid vid-xxxx_pid-yyyy

In this example, xxxx is the vendor ID and yyyy is the product ID of the USB Ethernet adapter.

USB Redirection Properties
When creating filtering rules, you can use the USB redirection properties.

Table 4‑4.  Configuration Properties for USB Redirection

Policy Name and Property Description

Allow Auto Device Splitting
Property:
AllowAutoDeviceSplitting

Allow the automatic splitting of composite USB devices.
The default value is undefined, which equates to false.

Exclude Vid/Pid Device From Split
Property:
SplitExcludeVidPid

Excludes a composite USB device specified by vendor and product IDs from
splitting. The format of the setting is vid-xxx1_pid-yyy1[;vid-xxx2_pid-yyy2]...
You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0781_pid-55**
The default value is undefined.
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Table 4‑4.  Configuration Properties for USB Redirection (Continued)

Policy Name and Property Description

Split Vid/Pid Device
Property:
SplitVidPid

Treats the components of a composite USB device specified by vendor and product
IDs as separate devices. The format of the setting is
vid-xxxx_pid-yyyy([exintf:zz[;exintf:ww ]])[;...]
You can use the exintf keyword to exclude components from redirection by
specifying their interface number. You must specify ID numbers in hexadecimal,
and interface numbers in decimal including any leading zero. You can use the
wildcard character (*) in place of individual digits in an ID.
For example: vid-0781_pid-554c(exintf:01;exintf:02)
NOTE   If the composite device includes components that are automatically
excluded, such as mouse and keyboard components, then View does not
automatically include the components that you have not explicitly excluded. You
must specify a filter policy such as Include Vid/Pid Device to include those
components.
The default value is undefined.

Allow Audio Input Devices
Property:
AllowAudioIn

Allows audio input devices to be redirected.
The default value is undefined, which equates to true.

Allow Audio Output Devices
Property:
AllowAudioOut

Allows audio output devices to be redirected.
The default value is undefined, which equates to false.

Allow HID
Property:
AllowHID

Allows input devices other than keyboards or mice to be redirected.
The default value is undefined, which equates to true.

Allow HIDBootable
Property:
AllowHIDBootable

Allows input devices other than keyboards or mice that are available at boot time
(also known as hid-bootable devices) to be redirected.
The default value is undefined, which equates to true.

Allow Device Descriptor Failsafe
Property:
AllowDevDescFailsafe

Allows devices to be redirected even if the Horizon Client fails to get the
config/device descriptors.
To allow a device even if it fails the config/desc, include it in the Include filters, such
IncludeVidPid or IncludePath.
The default value is undefined, which equates to false.

Allow Keyboard and Mouse Devices
Property:
AllowKeyboardMouse

Allows keyboards with integrated pointing devices (such as a mouse, trackball, or
touch pad) to be redirected.
The default value is undefined, which equates to false.

Allow Smart Cards
Property:
AllowSmartcard

Allows smart-card devices to be redirected.
The default value is undefined, which equates to false.

Allow Video Devices
Property:
AllowVideo

Allows video devices to be redirected.
The default value is undefined, which equates to true.

Disable Remote Configuration Download
Property:
DisableRemoteConfig

Disables the use of View Agent settings when performing USB device filtering.
The default value is undefined, which equates to false.

Exclude All Devices
Property:
ExcludeAllDevices

Excludes all USB devices from being redirected. If set to true, you can use other
policy settings to allow specific devices or families of devices to be redirected. If set
to false, you can use other policy settings to prevent specific devices or families of
devices from being redirected.
If you set the value of Exclude All Devices to true on View Agent, and this
setting is passed to Horizon Client, the View Agent setting overrides the
Horizon Client setting.
The default value is undefined, which equates to false.
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Table 4‑4.  Configuration Properties for USB Redirection (Continued)

Policy Name and Property Description

Exclude Device Family
Property:
ExcludeFamily

Excludes families of devices from being redirected. The format of the setting is
family_name_1[;family_name_2]...
For example: bluetooth;smart-card
The default value is undefined.
NOTE   If you have enabled automatic device splitting, View examines the device
family of each interface of a composite USB device to decide which interfaces
should be excluded. If you have disabled automatic device splitting, View examines
the device family of the whole composite USB device.

Exclude Vid/Pid Device
Property:
ExcludeVidPid

Excludes devices with specified vendor and product IDs from being redirected. The
format of the setting is vid-xxx1_pid-yyy2[;vid-xxx2_pid-yyy2]...
You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0781_pid-****;vid-0561_pid-554c
The default value is undefined.

Exclude Path
Property:
ExcludePath

Exclude devices at specified hub or port paths from being redirected. The format of
the setting is bus-x1[/y1]..._port-z1[;bus-x2[/y2]..._port-z2]...
You must specify bus and port numbers in hexadecimal. You cannot use the
wildcard character in paths.
For example: bus-1/2/3_port-02;bus-1/1/1/4_port-ff
The default value is undefined.

Include Device Family
Property:
IncludeFamily

Includes families of devices that can be redirected. The format of the setting is
family_name_1[;family_name_2]...
For example: storage
The default value is undefined.

Include Path
Property:
IncludePath

Include devices at a specified hub or port paths that can be redirected. The format of
the setting is bus-x1[/y1]..._port-z1[;bus-x2[/y2]..._port-z2]...
You must specify bus and port numbers in hexadecimal. You cannot use the
wildcard character in paths.
For example: bus-1/2_port-02;bus-1/7/1/4_port-0f
The default value is undefined.

Include Vid/Pid Device
Property:
IncludeVidPid

Includes devices with specified vendor and product IDs that can be redirected. The
format of the setting is vid-xxx1_pid-yyy2[;vid-xxx2_pid-yyy2]...
You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0561_pid-554c
The default value is undefined.

USB Device Families
You can specify a family when you are creating USB filtering rules for Horizon Client or View Agent.

NOTE   Some devices do not report a device family.

Table 4‑5.  USB Device Families

Device Family
Name Description

audio Any audio-input or audio-output device.

audio-in Audio-input devices such as microphones.

audio-out Audio-output devices such as loudspeakers and headphones.

bluetooth Bluetooth-connected devices.
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Table 4‑5.  USB Device Families (Continued)

Device Family
Name Description

comm Communications devices such as modems and wired networking adapters.

hid Human interface devices excluding keyboards and pointing devices.

hid-bootable Human interface devices that are available at boot time excluding keyboards and pointing devices.

imaging Imaging devices such as scanners.

keyboard Keyboard device.

mouse Pointing device such as a mouse.

other Family not specified.

pda Personal digital assistants.

physical Force feedback devices such as force feedback joysticks.

printer Printing devices.

security Security devices such as fingerprint readers.

smart-card Smart-card devices.

storage Mass storage devices such as flash drives and external hard disk drives.

unknown Family not known.

vendor Devices with vendor-specific functions.

video Video-input devices.

wireless Wireless networking adapters.

wusb Wireless USB devices.

Turn on Logging for USB Redirection
You can use USB logs to troubleshoot and to determine the product ID and vendor ID of various devices
you plug in to the client system.

You can enable trace logging either just for the current session or across reboots. To enable logging for the
current session, you use a shell command. To enable logging across reboots, add the shell command to the
appropriate profile file.

Prerequisites

If you plan to configure trace logging to persist across system reboots, you must have Administrator or root
permissions on the client system. This prerequisite does not apply if you plan to enable logging for the
current session only.

Procedure

n To enable logging for the current session only, use the launchctl command.

a Quit Horizon Client so that the USB service daemon is stopped.

b Open a shell (/Applications/Utilities/Terminal.app) as the same user who starts Horizon Client.

c Use the following command:

launchctl setenv VMWARE_VIEW_USBD_LOG_OPTIONS "-o log:trace"

d Restart Horizon Client.
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n To enable logging across reboots, add the launchctl command to the appropriate shell rc or profile file
for your choice of shell, such as ~/.bash_profile for the default Mac OS X shell.

Following is an example of the launchctl command to add:

setenv VMWARE_VIEW_USBD_LOG_OPTIONS "-o log:trace"

Using the Real-Time Audio-Video Feature for Webcams and
Microphones

With the Real-Time Audio-Video feature, you can use your local computer's webcam or microphone on
your remote desktop. Real-Time Audio-Video is compatible with standard conferencing applications and
browser-based video applications, and supports standard webcams, audio USB devices, and analog audio
input.

This feature is available when used in conjunction with View 5.2 Feature Pack 2 or a later release. For
information about setting up the Real-Time Audio-Video feature and configuring the frame rate and image
resolution in a remote desktop, see the VMware Horizon View Feature Pack Installation and Administration
guide. For information about configuring these settings on client systems, see the VMware knowledge base
article Setting Frame Rates and Resolution for Real-Time Audio-Video on Horizon View Clients, at 
http://kb.vmware.com/kb/2053644.

To download a test application that verifies the correct installation and operation of the Real-Time Audio-
Video functionality, go to http://labs.vmware.com/flings/real-time-audio-video-test-application. This test
application is available as a VMware fling, and therefore no technical support is available for it.

When You Can Use Your Webcam
If a View administrator has configured the Real-Time Audio-Video feature, and if you use the PCoIP display
protocol, a webcam that is built-in or connected to your local computer can be used on your desktop. You
can use the webcam in conferencing applications such as Skype, Webex, or Google Hangouts.

During the setup of an application such as Skype, Webex, or Google Hangouts on your remote desktop, you
can choose VMware Virtual Microphone and VMware Virtual Webcam as input devices and VMware
Virtual Audio as output device from menus in the application. With many applications, however, this
feature will just work, and selecting an input device will not be necessary.

If the webcam is currently being used by your local computer, it can be used by the remote desktop
simultaneously. Also, if the webcam is being used by the remote desktop, it can be used by your local
computer at the same time.

NOTE   If you are using a USB webcam, do not connect it from the Connection > USB menu in
Horizon Client. To do so routes the device through USB redirection and the performance will be unusable
for video chat.

If you have more than one webcam connected to your local computer, you can configure a preferred
webcam to use on your remote desktop.

Select a Default Microphone on a Mac OS X Client System
If you have multiple microphones on your client system, only one microphone is used on your remote
desktop. You can use System Preferences on your client system to specify which microphone is the default
microphone on the remote desktop.

With the Real-Time Audio-Video feature, audio input devices and audio output devices work without
requiring the use of USB redirection, and the amount of network bandwidth required is greatly reduced.
Analog audio input devices are also supported.
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This procedure describes how to choose a microphone from the user interface of the client system.
Administrators can also configure a preferred microphone by using the Mac OS X defaults system. See 
“Configure a Preferred Webcam or Microphone on a Mac OS X Client System,” on page 47.

IMPORTANT   If you are using a USB microphone, do not connect it from the Connection > USB menu in
Horizon Client. To do so routes the device through USB redirection and the device cannot use the Real-Time
Audio-Video feature.

Prerequisites

n Verify that you have a USB microphone or another type of microphone installed and operational on
your client system.

n Verify that you are using the PCoIP display protocol for your remote desktop.

Procedure

1 On your client system, select Apple menu > System Preferences and click Sound.

2 Open the Input pane of Sound preferences.

3 Select the microphone that you prefer to use.

The next time that you connect to a remote desktop and start a call, the desktop uses the default microphone
that you selected on the client system.

Configuring Real-Time Audio-Video on a Mac OS X Client
You can configure Real-Time Audio-Video settings at the command line by using the Mac OS X defaults
system. With the defaults system, you can read, write, and delete Mac OS X user defaults by using Terminal
(/Applications/Utilities/Terminal.app).

Mac OS X defaults belong to domains. Domains typically correspond to individual applications. The
domain for the Real-Time Audio-Video feature is com.vmware.rtav.

Syntax for Configuring Real-Time Audio-Video
You can use the following commands to configure the Real-Time Audio-Video feature.

Table 4‑6.  Command Syntax for Real-Time Audio-Video Configuration

Command Description

defaults write com.vmware.rtav scrWCamId "webcam-
userid"

Sets the preferred webcam to use on remote desktops. When this
value is not set, the webcam is selected automatically by system
enumeration. You can specify any webcam connected to (or built
into) the client system.

defaults write com.vmware.rtav srcAudioInId "audio-
device-userid"

Sets the preferred microphone (audio-in device) to use on remote
desktops. When this value is not set, remote desktops use the
default recording device set on the client system. You can specify
any microphone connected to (or built into) the client system.

defaults write com.vmware.rtav srcWCamFrameWidth
pixels

Sets the image width. The value defaults to a hardcoded value of
320 pixels. You can change the image width to any pixel value.

defaults write com.vmware.rtav srcWCamFrameHeight
pixels

Sets the image height. The value defaults to a hardcoded value of
240 pixels. You can change the image height to any pixel value.

defaults write com.vmware.rtav srcWCamFrameRate fps Sets the frame rate. The value defaults to 15 fps. You can change
the frame rate to any value.

defaults write com.vmware.rtav LogLevel "level" Sets the logging level for the Real-Time Audio-Video log file
(~/Library/Logs/VMware/vmware-RTAV-pid.log). You can set
the logging level to trace or debug.
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Table 4‑6.  Command Syntax for Real-Time Audio-Video Configuration (Continued)

Command Description

defaults write com.vmware.rtav IsDisabled value Determines whether Real-Time Audio-Video is enabled or
disabled. Real-Time Audio-Video is enabled by default. (This
value is not in effect.) To disable Real-Time Audio-Video on the
client, set the value to true.

defaults read com.vmware.rtav Displays Real-Time Audio-Video configuration settings.

defaults delete com.vmware.rtav setting Deletes a Real-Time Audio-Video configuration setting, for
example: defaults delete com.vmware.rtav
srcWCamFrameWidth

NOTE   You can adjust frame rates from 1 fps up to a maximum of 25 fps and resolution up to a maximum of
1920x1080. A high resolution at a fast frame rate might not be supported on all devices or in all
environments.

Configure a Preferred Webcam or Microphone on a Mac OS X Client System
With the Real-Time Audio-Video feature, if you have multiple webcams or microphones on your client
system, only one webcam and one microphone can be used on your remote desktop. You specify which
webcam and microphone are preferred at the command line by using the Mac OS X defaults system.

With the Real-Time Audio-Video feature, webcams, audio input devices, and audio output devices work
without requiring USB redirection, and the amount of network bandwidth required is greatly reduced.
Analog audio input devices are also supported.

In most environments, there is no need to configure a preferred microphone or webcam. If you do not set a
preferred microphone, remote desktops use the default audio device set in the client system's System
Preferences. See “Select a Default Microphone on a Mac OS X Client System,” on page 45. If you do not
configure a preferred webcam, the remote desktop selects the webcam by enumeration.

Prerequisites

n If you are configuring a preferred USB webcam, verify that the webcam is installed and operational on
your client system.

n If you are configuring a preferred USB microphone or other type of microphone, verify that the
microphone is installed and operational on your client system.

n Verify that you are using the PCoIP display protocol for your remote desktop.

Procedure

1 On your Mac OS X client system, start a webcam or microphone application to trigger an enumeration
of camera devices or audio devices to the Real-Time Audio-Video log file.

a Attach the webcam or audio device.

b In the Applications folder, double-click VMware Horizon View Client (Horizon Client 3.0) or
VMware Horizon Client (Horizon Client 3.1 and later) to start Horizon Client.

c Start a call and then stop the call.
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2 Find log entries for the webcam or microphone in the Real-Time Audio-Video log file.

a In a text editor, open the Real-Time Audio-Video log file.

The Real-Time Audio-Video log file is named ~/Library/Logs/VMware/vmware-RTAV-pid.log, where
pid is the process ID of the current session.

b Search the Real-Time Audio-Video log file for entries that identify the attached webcams or
microphones.

The following example shows how webcam entries might appear in the Real-Time Audio-Video log file:

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void VideoInputBase::LogDevEnum() - 

1 Device(s) found

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void VideoInputBase::LogDevEnum() - 

Name=FaceTime HD Camera (Built-in)   UserId=FaceTime HD Camera (Built-

in)#0xfa20000005ac8509   SystemId=0xfa20000005ac8509

The following example shows how microphone entries might appear in the Real-Time Audio-Video log
file:

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: int 

AVCaptureEnumerateAudioDevices(MMDev::DeviceList&) - 

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum() 

- 2 Device(s) found

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum() 

- Index=255   Name=Built-in Microphone   UserId=Built-in Microphone#AppleHDAEngineInput:1B,

0,1,0:1   SystemId=AppleHDAEngineInput:1B,0,1,0:1

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum() 

- Index=255   Name=Built-in Input   UserId=Built-in Input#AppleHDAEngineInput:1B,0,1,1:2   

SystemId=AppleHDAEngineInput:1B,0,1,1:2

3 Find the webcam or microphone that you prefer in the Real-Time Audio-Video log file and make a note
of its user ID.

The user ID appears after the string UserId= in the log file. For example, the user ID of the internal face
time camera is FaceTime HD Camera (Built-in) and the user ID of the internal microphone is Built-in
Microphone.

4 In Terminal (/Applications/Utilities/Terminal.app), use the defaults write command to set the
preferred webcam or microphone.

Option Action

Set the preferred webcam Type
defaults write com.vmware.rtav srcWCamId "webcam-userid",
where webcam-userid is the user ID of the preferred webcam, which you
obtained from the Real-Time Audio-Video log file. For example:
defaults write com.vmware.rtav srcWCamId "HD Webcam C525”

Set the preferred microphone Type
defaults write com.vmware.rtav srcAudioInId "audio-device-
userid", where audio-device-userid is the user ID of the preferred
microphone, which you obtained from the Real-Time Audio-Video log file.
For example:
defaults write com.vmware.rtav srcAudioInId "Built-in 
Microphone"

 
5 (Optional) Use the defaults read command to verify your changes to the Real-Time Audio-Video

feature.

For example: defaults read com.vmware.rtav

The command lists all of the Real-Time Audio-Video settings.
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The next time you connect to a remote desktop and start a new call, the desktop uses the preferred webcam
or microphone that you configured, if it is available. If the preferred webcam or microphone is not available,
the remote desktop can use another available webcam or microphone.

Copying and Pasting Text and Images
By default, you can copy and paste text from your client system to a remote desktop or application. If your
administrator enables the feature, you can also copy and paste text from a remote desktop or application to
your client system or between two remote desktops or applications. Some restrictions apply.

If you use the PCoIP display protocol and you are using a View 5.x or later remote desktop, your View
administrator can set this feature so that copy and paste operations are allowed only from your client
system to a remote desktop, or only from a remote desktop to your client system, or both, or neither. If you
are using a Horizon 6.0 with View remote application, the same rules apply.

Administrators configure the ability to copy and paste by using group policy objects (GPOs) that pertain to
View Agent in remote desktops or applications. For more information, see the topic about View PCoIP
general session variables, which includes the setting called Configure clipboard redirection in the Setting
Up Desktop and Application Pools for View document, in the chapter about configuring policies.

Supported file formats include text, images, and RTF (Rich Text Format). The clipboard can accommodate
1MB of data for copy and paste operations. If you are copying formatted text, some of the data is text and
some of the data is formatting information. For example, an 800KB document might use more than 1MB of
data when it is copied because more than 200KB of RTF data might get put in the clipboard.

If you copy a large amount of formatted text or text and an image, when you attempt to paste the text and
image, you might see some or all of the plain text but no formatting or image. The reason is that the three
types of data are sometimes stored separately. For example, depending on the type of document you are
copying from, images might be stored as images or as RTF data.

If the text and RTF data together use less than 1MB, the formatted text is pasted. Often the RTF data cannot
be truncated, so that if the text and formatting use more than 1MB, the RTF data is discarded, and plain text
is pasted.

If you are unable to paste all of the formatted text and images you selected in one operation, you might need
to copy and paste smaller amounts in each operation.

You cannot copy and paste files between a remote desktop and the file system on your client computer.

Using Remote Applications
You can use many Mac functions with remote applications.

n When you run a remote application, its icon appears in the Dock. You can maximize a minimized
remote application by clicking its icon in the Dock.

n You can keep, open, and quit a remote application from its context menu in the Dock. If you select Keep
in Dock, the remote application icon remains in the Dock, even after you close all application windows.

n In Horizon Client 3.1 and later, you can launch a remote application by clicking its icon in the Dock.

n In Horizon Client 3.2, flashing Windows taskbar items are forwarded to Horizon Client. For example, if
the remote application is an IM client and you receive a new message, a flashing red dot appears on the
IM client's icon in the Dock.

n You can start voice dictation, minimize, and zoom a remote application from the menu bar.

n You can use the Exposé feature to see open remote applications, and you can press Command-Tab to
switch between open remote applications.
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n You can use standard OS X keyboard shortcuts to interact with remote applications. For example, you
can press Command-W to close an individual application window and Command-S to save the current
file. You can also use standard OS X keyboard shortcuts to copy, cut, and paste text between your OS X
applications and remote applications. In Horizon Client 3.2, you can customize keyboard shortcut
mappings. See “Configure Keyboard Shortcut Mappings,” on page 26.

n In Horizon Client 3.1 and later, if a remote application creates a Windows System Tray item, that item
appears in the notification area on the menu bar on your Mac client system. You can interact with this
item from the notification area on your Mac in the same way that you would interact with it from the
System Tray on a Windows system.

NOTE   When you re-click a redirected System Tray item in the notification area on your Mac, the
context menu does not disappear.

Saving Documents in a Remote Application
With certain remote applications, such as Microsoft Word or WordPad, you can create and save documents.
Where these documents are saved depends on your company's network environment. For example, your
documents might be saved to a home share mounted on your local computer.

Administrators can use an ADMX template file to set a group policy that specifies where documents are
saved. This policy is called "Set Remote Desktop Services User Home Directory." For more information, see
the "RDS Profiles Settings" topic in the Setting Up Desktop and Application Pools in View document.

Printing from a Remote Desktop
From a remote desktop, you can print to a virtual printer or to a USB printer that is attached to your client
computer. Virtual printing and USB printing work together without conflict.

Enabling Virtual Printing on the Mac OS X Client
When you use the PCoIP display protocol, you can use printers configured for your local computer from a
remote desktop or application.

The virtual printing feature is available with no driver installation required.

When the virtual printing feature is enabled, the Connection menu displays Printing Enabled.

You can enable virtual printing the first time you launch Horizon Client. Click Continue when
Horizon Client prompts you to start remote desktop USB and printing services and type your system
credentials.

NOTE   If you install Horizon Client for Mac OS X on a Mac on which VMware Fusion was previously
launched, printing services will already be enabled when you launch Horizon Client. This behavior occurs
because VMware Fusion and Horizon Client use some of the same files to implement virtual printing.

If you do not enable virtual printing the first time you launch Horizon Client, you can use the Connection
menu to enable virtual printing.

n To enable virtual printing before you connect to a remote desktop or application, select Connection >
Start Printing Services from the VMware Horizon View Client (Horizon Client 3.0) or VMware
Horizon Client (Horizon Client 3.1 and later) menu. Click Continue in the dialog box and type your
system credentials.

n To enable virtual printing after you connect to a desktop, select Connection > Start Printing Services
from the VMware Horizon View Client (Horizon Client 3.0) or VMware Horizon Client (
Horizon Client 3.1 and later) menu. Click Continue, type your system credentials, and reconnect to the
desktop or application. If you cancel the reconnection, you can click Connection > Enable Printing and
Horizon Client prompts you to reconnect again.
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Set Printing Preferences for the Virtual Printer Feature on a Remote Desktop
The virtual printing feature lets end users use local or network printers from a remote desktop without
requiring that additional print drivers be installed in the remote desktop. For each printer available through
this feature, you can set preferences for data compression, print quality, double-sided printing, color, and so
on.

After a printer is added on the local computer, Horizon Client adds that printer to the list of available
printers on the remote desktop. No further configuration is required. Users who have administrator
privileges can still install printer drivers on the remote desktop without creating a conflict with the virtual
printer component.

IMPORTANT   This feature is not available for the following types of printers:

n USB printers that are using the USB redirection feature to connect to a virtual USB port in the remote
desktop

You must disconnect the USB printer from the remote desktop in order to use the virtual printing
feature with it.

n The Windows feature for printing to a file

Selecting the Print to file check box in a Print dialog box does not work. Using a printer driver that
creates a file does work. For example, you can use a PDF writer to print to a PDF file.

This procedure is written for a remote desktop that has a Windows 7 or Windows 8.x (Desktop) operating
system. The procedure is similar but not exactly the same for Windows XP and Windows Vista.

Prerequisites

Verify that the Virtual Printing component of View Agent is installed on the remote desktop. In the remote
desktop file system, verify that the following folder exists: C:\Program Files\Common Files\ThinPrint.

Installing View Agent is one of the tasks required for preparing a virtual machine to be used as a remote
desktop. For more information, see the View Administration document if you are using View Connection
Server and View Agent 5.x or an earlier version. See Setting Up Desktop and Application Pools in View if you
are using View Connection Server and View Agent 6.0 or later.

Procedure

1 In the Windows 7 or Windows 8.x remote desktop, click Start > Devices and Printers.

2 In the Devices and Printers window, right-click the default printer, select Printer Properties from the
context menu, and select the printer.

In the remote desktop, virtual printers appear as <printer_name>#:<number>.

3 In the Printer Properties window, click the Device Setup tab and specify which settings to use.

4 On the General tab, click Preferences and specify which settings to use.

5 In the Printing Preferences dialog box, select the different tabs and specify which settings to use.

For the Page Adjustment advanced setting, VMware recommends that you retain the default settings.

6 Click OK.
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Using USB Printers
In an View environment, virtual printers and redirected USB printers can work together without conflict.

A USB printer is a printer that is attached to a USB port on the local client system. To send print jobs to a
USB printer, you can either use the USB redirection feature or use the virtual printing feature. USB printing
can sometimes be faster than virtual printing, depending on network conditions.

n You can use the USB redirection feature to attach a USB printer to a virtual USB port in the remote
desktop as long as the required drivers are also installed on the remote desktop.

If you use this redirection feature the printer is no longer logically attached to the physical USB port on
the client and this is why the USB printer does not appear in the list of local printers on the local client
machine. This also means that you can print to the USB printer from the remote desktop but not from
the local client machine.

In the remote desktop, redirected USB printers appear as <printer_name>.

For information about how to connect a USB printer, see “Connect USB Devices,” on page 38.

n On some clients, you can alternatively use the virtual printing feature to send print jobs to a USB
printer. If you use the virtual printing feature you can print to the USB printer from both the remote
desktop and the local client, and you do not need to install print drivers on the remote desktop.

PCoIP Client-Side Image Cache
PCoIP client-side image caching stores image content on the client to avoid retransmission. This feature
reduces bandwidth usage.

IMPORTANT   This feature is available only when the version of View Agent and View Connection Server is
View 5.0 or later.

The PCoIP image cache captures spatial, as well as temporal, redundancy. For example, when you scroll
down through a PDF document, new content appears from the bottom of the window and the oldest content
disappears from the top of the window. All the other content remains constant and moves upward. The
PCoIP image cache is capable of detecting this spatial and temporal redundancy.

Because during scrolling, the display information sent to the client device is primarily a sequence of cache
indices, using the image cache saves a significant amount of bandwidth. This efficient scrolling has benefits
both on the LAN and over the WAN.

n On the LAN, where bandwidth is relatively unconstrained, using client-side image caching delivers
significant bandwidth savings.

n Over the WAN, to stay within the available bandwidth constraints, scrolling performance would be
degraded without client-side caching. Over the WAN, client-side caching saves bandwidth and ensure
a smooth, highly responsive scrolling experience.

With client-side caching, the client stores portions of the display that were previously transmitted. The cache
size is 250MB.

If you use View 5.2 servers and desktops, a 90MB client-side cache gives the equivalent performance of
using a 250MB cache with earlier versions.
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Troubleshooting Horizon Client 5
You can solve most problems with Horizon Client by resetting the desktop or by reinstalling the
VMware Horizon Client application.

This chapter includes the following topics:

n “Reset a Remote Desktop or Application,” on page 53

n “Uninstalling Horizon Client,” on page 54

Reset a Remote Desktop or Application
You might need to reset a desktop or application if the application or desktop operating system stops
responding. Resetting a remote desktop shuts down and restarts the desktop. Resetting your remote
applications quits the applications. Unsaved data is lost.

Resetting a remote desktop is the equivalent of pressing the Reset button on a physical PC to force the PC to
restart. Any files that are open on the remote desktop will be closed without being saved first.

Resetting applications is the equivalent of quitting all remote applications without saving any unsaved data.
All open applications are closed, even if the applications come from different RDS server farms.

You can reset a remote desktop or application only if your administrator has enabled this feature.

Procedure

u Use the Reset command.

Option Action

Reset a remote desktop from within
the desktop

Select Connection > Reset from the menu bar.

Reset a remote desktop from the
desktop and application selection
window

Select the remote desktop and select Connection > Reset from the menu
bar.

Reset remote applications from the
desktop and application selection
window

Click the Settings button (gear icon) in the upper right corner of the
window, select Applications in the left pane, click Reset, and click
Continue.

 
For a remote desktop, the operating system in the remote desktop is rebooted. Horizon Client disconnects
from the desktop. For remote applications, the applications are quit.

What to do next

Wait an appropriate amount of time for system startup before attempting to connect to the remote desktop.
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Uninstalling Horizon Client
You can sometimes resolve problems with Horizon Client by uninstalling and reinstalling the
Horizon Client application.

You uninstall Horizon Client by using the same method that you usually use to uninstall any other
application.

Drag the VMware Horizon View Client (Horizon Client 3.0) or VMware Horizon Client (Horizon Client
3.1 and later) application from the Applications folder to the Trash and empty the trash.

After uninstalling is complete, you can reinstall the application.

See “Install Horizon Client on Mac OS X,” on page 10.
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